about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-02-07 18:10:58 +0900
committersefidel <contact@sefidel.net>2023-02-07 18:10:58 +0900
commitcd7df8d2ea9234e4db8ddc831c065dd6da2b9382 (patch)
tree694e2cc80e10889a1177bd0310c722e83cc9a51f /home/default.nix
parentee89dcea57a36e856b53fa178284a7f80d3a4839 (diff)
downloadnixrc-cd7df8d2ea9234e4db8ddc831c065dd6da2b9382.tar.gz
nixrc-cd7df8d2ea9234e4db8ddc831c065dd6da2b9382.zip
feat(flake): bump
TODO: uncomment neovim overlay,
see comments in relevant section
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/home/default.nix b/home/default.nix
index 30ab75f..d4f112b 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -1,10 +1,12 @@
 { self, unstable, ... } @ inputs:
 
 {
+  # TODO See: https://github.com/neovim/neovim/pull/21711
+  # TODO See: https://github.com/NixOS/nixpkgs/pull/214231
   "zach@alpha" = self.lib.mkHome {
     username = "zach";
     hostname = "alpha";
-    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ chaotic-nixpkgs.overlay rust.overlays.default neovim.overlay ]; };
+    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ chaotic-nixpkgs.overlay rust.overlays.default /*neovim.overlay*/ ]; };
 
     extraModules = [
       ./profiles/populate.nix
@@ -22,7 +24,7 @@
   "o32@kompakt" = self.lib.mkHome {
     username = "o32";
     hostname = "kompakt";
-    pkgs = import unstable { system = "aarch64-darwin"; overlays = with inputs; [ rust.overlays.default neovim.overlay ]; };
+    pkgs = import unstable { system = "aarch64-darwin"; overlays = with inputs; [ rust.overlays.default /*neovim.overlay*/ ]; };
 
     extraModules = [
       ./profiles/populate.nix