about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/foot.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-01 01:44:39 +0900
committersefidel <contact@sefidel.net>2022-01-01 01:46:13 +0900
commit34e2f2666627a516a73df8f7c19b3abac75050d6 (patch)
tree054a9b49601d2af342123cf9902a956216ddb87f /home/modules/profiles/base/config/foot.nix
parent4dae1769aaf420643f99685c420197239f6b8755 (diff)
downloadnixrc-34e2f2666627a516a73df8f7c19b3abac75050d6.tar.gz
nixrc-34e2f2666627a516a73df8f7c19b3abac75050d6.zip
home/neotheme: init
Diffstat (limited to 'home/modules/profiles/base/config/foot.nix')
-rw-r--r--home/modules/profiles/base/config/foot.nix42
1 files changed, 23 insertions, 19 deletions
diff --git a/home/modules/profiles/base/config/foot.nix b/home/modules/profiles/base/config/foot.nix
index d53dba7..c47f689 100644
--- a/home/modules/profiles/base/config/foot.nix
+++ b/home/modules/profiles/base/config/foot.nix
@@ -1,3 +1,7 @@
+{ neotheme }:
+
+with neotheme.palette.colors;
+
 {
   main = {
     term = "foot";
@@ -11,23 +15,23 @@
   cursor.style = "beam";
 
   colors = {
-    background = "18191f";
-    foreground = "cbc0ab";
-    regular0 = "222329";
-    regular1 = "b17f81";
-    regular2 = "8aa387";
-    regular3 = "d4ae80";
-    regular4 = "8896ae";
-    regular5 = "c495a2";
-    regular6 = "7aacaa";
-    regular7 = "d0d0c7";
-    bright0 = "36373d";
-    bright1 = "c59395";
-    bright2 = "9eb79b";
-    bright3 = "e8c294";
-    bright4 = "9caac2";
-    bright5 = "d8a9b6";
-    bright6 = "8ec0be";
-    bright7 = "e4e4db";
+    background = background;
+    foreground = foreground;
+    regular0 = color0;
+    regular1 = color1;
+    regular2 = color2;
+    regular3 = color3;
+    regular4 = color4;
+    regular5 = color5;
+    regular6 = color6;
+    regular7 = color7;
+    bright0 = bright0;
+    bright1 = bright1;
+    bright2 = bright2;
+    bright3 = bright3;
+    bright4 = bright4;
+    bright5 = bright5;
+    bright6 = bright6;
+    bright7 = bright7;
   };
-}
\ No newline at end of file
+}