about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/waybar-style.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2021-12-28 01:11:25 +0900
committersefidel <contact@sefidel.net>2021-12-28 01:12:48 +0900
commit56992b8c945d497a623fe693847c91235be1ae02 (patch)
tree102ff8c8872d7e14ce3e3dba69bf16685374504e /home/modules/profiles/base/config/waybar-style.nix
downloadnixrc-56992b8c945d497a623fe693847c91235be1ae02.tar.gz
nixrc-56992b8c945d497a623fe693847c91235be1ae02.zip
initial commit
Diffstat (limited to 'home/modules/profiles/base/config/waybar-style.nix')
-rw-r--r--home/modules/profiles/base/config/waybar-style.nix97
1 files changed, 97 insertions, 0 deletions
diff --git a/home/modules/profiles/base/config/waybar-style.nix b/home/modules/profiles/base/config/waybar-style.nix
new file mode 100644
index 0000000..45edf60
--- /dev/null
+++ b/home/modules/profiles/base/config/waybar-style.nix
@@ -0,0 +1,97 @@
+''
+  * {
+    border: none;
+    border-radius: 0;
+    font-family: "JetBrainsMono Nerd Font";
+    font-size: 14px;
+    min-height: 0;
+  }
+
+  window#waybar {
+    background: #18191f;
+    color: #cbc0ab;
+  }
+
+  #workspaces button {
+    padding: 0 4px;
+    background: #c495a2;
+    color: #18191f;
+    border-bottom: 2px solid #c495a2;
+  }
+
+  #workspaces button.focused {
+    background: #c495a2;
+    border-bottom: 2px solid #18191f;
+  }
+
+  #clock,
+  #cpu,
+  #battery,
+  #temperature,
+  #backlight,
+  #network,
+  #memory,
+  #language,
+  #pulseaudio,
+  #tray,
+  #mode,
+  #mpd,
+  #custom-weather {
+    padding: 0 6px;
+    margin: 0;
+    background-color: #c495a2;
+    color: #18191f;
+  }
+
+  @keyframes blink {
+    to {
+      background-color: #c495a2;
+      color: #18191f;
+    }
+  }
+
+  #cpu {
+    background-color: #8bb0a6;
+  }
+
+  #network {
+    background-color: #8bb0a6;
+  }
+
+  #memory {
+    background-color: #8bb0a6;
+  }
+
+  #pulseaudio {
+    background-color: #8bb0a6;
+  }
+
+  #battery {
+    background-color: #8bb0a6;
+  }
+
+  #battery.full {
+    background-color: #8bb0a6;
+    color: #18191f;
+  }
+
+  #battery.discharging {
+    background-color: #8bb0a6;
+    color: #18191f;
+  }
+
+  #battery.charging {
+    background-color: #8bb0a6;
+    color: #18191f;
+  }
+
+  #battery.warning:not(.charging) {
+    background-color: #8bb0a6;
+    color: #18191f;
+    animation-name: blink;
+    animation-duration: 0.5s;
+    animation-timing-function: linear;
+    animation-iteration-count: infinite;
+    animation-direction: alternate;
+  }
+''