about summary refs log tree commit diff
path: root/home/modules/profiles/base/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-01 01:44:39 +0900
committersefidel <contact@sefidel.net>2022-01-01 01:46:13 +0900
commit34e2f2666627a516a73df8f7c19b3abac75050d6 (patch)
tree054a9b49601d2af342123cf9902a956216ddb87f /home/modules/profiles/base/default.nix
parent4dae1769aaf420643f99685c420197239f6b8755 (diff)
downloadnixrc-34e2f2666627a516a73df8f7c19b3abac75050d6.tar.gz
nixrc-34e2f2666627a516a73df8f7c19b3abac75050d6.zip
home/neotheme: init
Diffstat (limited to 'home/modules/profiles/base/default.nix')
-rw-r--r--home/modules/profiles/base/default.nix232
1 files changed, 132 insertions, 100 deletions
diff --git a/home/modules/profiles/base/default.nix b/home/modules/profiles/base/default.nix
index 96522ef..5b23f9e 100644
--- a/home/modules/profiles/base/default.nix
+++ b/home/modules/profiles/base/default.nix
@@ -2,122 +2,154 @@
 let
   cfg = config.profiles.base;
 
+  neotheme = config.neotheme;
+
   inherit (self.packages.x86_64-linux) neovim iosevka-pure-bin sf-mono-liga-bin phocus wallpapers;
 in
-  {
-    options.profiles.base.enable = lib.mkEnableOption
-      "The base profile, should be always enabled";
-
-    config = lib.mkIf cfg.enable {
-      home.sessionVariables = rec {
-        EDITOR = "nvim";
-        VISUAL = "nvim";
-        GIT_EDITOR = EDITOR;
-      };
-
-      gtk.enable = true;
-      gtk.iconTheme.package = pkgs.papirus-icon-theme;
-      gtk.iconTheme.name = "Papirus-Dark";
-      gtk.theme.package = phocus;
-      gtk.theme.name = "phocus";
-
-      home.keyboard.layout = "us";
-      home.packages = [
-        pkgs.hydra-check
-        neovim
-
-        # Fonts
-        iosevka-pure-bin
-        sf-mono-liga-bin
-	pkgs.dina-font
-	pkgs.sarasa-gothic
-	pkgs.scientifica
-        pkgs.jetbrains-mono
-        pkgs.twemoji-color-font
-        pkgs.symbola
-        pkgs.emacs-all-the-icons-fonts
-        (pkgs.nerdfonts.override { fonts = [ "Iosevka" "JetBrainsMono" ]; })
-      ];
-
-
-      wayland.windowManager.sway = {
-        enable = true;
+{
+  options.profiles.base.enable = lib.mkEnableOption
+    "The base profile, should be always enabled";
+
+  config = lib.mkIf cfg.enable {
+    home.sessionVariables = rec {
+      EDITOR = "nvim";
+      VISUAL = "nvim";
+      GIT_EDITOR = EDITOR;
+    };
 
-        config = {
-          bars = [{ command = "${pkgs.waybar}/bin/waybar"; }];
-          keybindings = { };
+    gtk.enable = true;
+    gtk.iconTheme.package = pkgs.papirus-icon-theme;
+    gtk.iconTheme.name = "Papirus-Dark";
+    gtk.theme.package = phocus;
+    gtk.theme.name = "phocus";
+
+    neotheme = {
+      wallpaper = "${wallpapers}/nixos/nix-glow-fg-d4ae80.png";
+
+      palette = {
+        identifier = "nightlamp";
+        name = "Nightlamp Theme";
+
+        colors = {
+          background = "18191f";
+          foreground = "cbc0ab";
+          color0 = "222329";
+          color1 = "b17f81";
+          color2 = "8aa387";
+          color3 = "d4ae80";
+          color4 = "8896ae";
+          color5 = "c495a2";
+          color6 = "7aacaa";
+          color7 = "d0d0c7";
+          bright0 = "36373d";
+          bright1 = "c59395";
+          bright2 = "9eb79b";
+          bright3 = "e8c294";
+          bright4 = "9caac2";
+          bright5 = "d8a9b6";
+          bright6 = "8ec0be";
+          bright7 = "e4e4db";
         };
+      };
+    };
 
-        extraConfig = import ./config/sway.nix { inherit pkgs wallpapers; };
+    home.keyboard.layout = "us";
+    home.packages = [
+      pkgs.hydra-check
+      neovim
+
+      # Fonts
+      iosevka-pure-bin
+      sf-mono-liga-bin
+      pkgs.dina-font
+      pkgs.sarasa-gothic
+      pkgs.scientifica
+      pkgs.jetbrains-mono
+      pkgs.twemoji-color-font
+      pkgs.symbola
+      pkgs.emacs-all-the-icons-fonts
+      (pkgs.nerdfonts.override { fonts = [ "Iosevka" "JetBrainsMono" ]; })
+    ];
+
+
+    wayland.windowManager.sway = {
+      enable = true;
+
+      config = {
+        bars = [{ command = "${pkgs.waybar}/bin/waybar"; }];
+        keybindings = { };
       };
 
-      programs = {
-        bat.enable = true;
-        direnv.enable = true;
-        direnv.nix-direnv.enable = true;
-        exa.enable = true;
-        exa.enableAliases = true;
-        home-manager.enable = true;
-        htop.enable = true;
+      extraConfig = import ./config/sway.nix { inherit pkgs neotheme; };
+    };
 
-        foot = {
-          enable = true;
+    programs = {
+      bat.enable = true;
+      direnv.enable = true;
+      direnv.nix-direnv.enable = true;
+      exa.enable = true;
+      exa.enableAliases = true;
+      home-manager.enable = true;
+      htop.enable = true;
 
-          settings = import ./config/foot.nix;
-        };
+      foot = {
+        enable = true;
 
-        waybar = {
-          enable = config.wayland.windowManager.sway.enable;
+        settings = import ./config/foot.nix { inherit neotheme; };
+      };
 
-          settings = [ (import ./config/waybar-settings.nix) ];
+      waybar = {
+        enable = config.wayland.windowManager.sway.enable;
 
-          style = import ./config/waybar-style.nix;
-        };
+        settings = [ (import ./config/waybar-settings.nix) ];
 
-        zsh = {
-          enable = true;
-
-          enableCompletion = true;
-          enableAutosuggestions = true;
-
-          autocd = true;
-
-          dotDir = ".config/zsh";
-
-          plugins = [
-            {
-              name = "powerlevel10k";
-              src = pkgs.zsh-powerlevel10k;
-              file = "share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
-            }
-
-            {
-              name = "powerlevel10k-config";
-              src = lib.cleanSource ./p10k-config;
-              file = "p10k.zsh";
-            }
-
-            {
-              name = "zsh-syntax-highlighting";
-              src = pkgs.fetchFromGitHub {
-                owner = "zsh-users";
-                repo = "zsh-syntax-highlighting";
-                rev = "0.7.1";
-                sha256 = "03r6hpb5fy4yaakqm3lbf4xcvd408r44jgpv4lnzl9asp4sb9qc0";
-              };
-            }
-          ];
-
-          shellAliases = config.programs.zshell.aliases;
-        };
+        style = import ./config/waybar-style.nix { inherit neotheme; };
       };
 
-      services.wlsunset = {
+      zsh = {
         enable = true;
-        latitude = "36.5";
-        longitude = "127.2";
+
+        enableCompletion = true;
+        enableAutosuggestions = true;
+
+        autocd = true;
+
+        dotDir = ".config/zsh";
+
+        plugins = [
+          {
+            name = "powerlevel10k";
+            src = pkgs.zsh-powerlevel10k;
+            file = "share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+          }
+
+          {
+            name = "powerlevel10k-config";
+            src = lib.cleanSource ./p10k-config;
+            file = "p10k.zsh";
+          }
+
+          {
+            name = "zsh-syntax-highlighting";
+            src = pkgs.fetchFromGitHub {
+              owner = "zsh-users";
+              repo = "zsh-syntax-highlighting";
+              rev = "0.7.1";
+              sha256 = "03r6hpb5fy4yaakqm3lbf4xcvd408r44jgpv4lnzl9asp4sb9qc0";
+            };
+          }
+        ];
+
+        shellAliases = config.programs.zshell.aliases;
       };
+    };
 
-      nixpkgs.allowedUnfree = [ "symbola" ];
+    services.wlsunset = {
+      enable = true;
+      latitude = "36.5";
+      longitude = "127.2";
     };
-  }
+
+    nixpkgs.allowedUnfree = [ "symbola" ];
+  };
+}