about summary refs log tree commit diff
path: root/home/modules/profiles/browsing/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2021-12-28 01:11:25 +0900
committersefidel <contact@sefidel.net>2021-12-28 01:12:48 +0900
commit56992b8c945d497a623fe693847c91235be1ae02 (patch)
tree102ff8c8872d7e14ce3e3dba69bf16685374504e /home/modules/profiles/browsing/default.nix
downloadnixrc-56992b8c945d497a623fe693847c91235be1ae02.tar.gz
nixrc-56992b8c945d497a623fe693847c91235be1ae02.zip
initial commit
Diffstat (limited to 'home/modules/profiles/browsing/default.nix')
-rw-r--r--home/modules/profiles/browsing/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/modules/profiles/browsing/default.nix b/home/modules/profiles/browsing/default.nix
new file mode 100644
index 0000000..45f0ed5
--- /dev/null
+++ b/home/modules/profiles/browsing/default.nix
@@ -0,0 +1,13 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.browsing;
+in
+  {
+    options.profiles.browsing = {
+      enable = lib.mkEnableOption
+        "A profile that enables a browser for the GUI and the terminal";
+      };
+
+    config = lib.mkIf cfg.enable {
+      home.packages = with pkgs; [ firefox lynx ];
+    };
+  }