about summary refs log tree commit diff
path: root/home/modules/profiles/browsing/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-01 15:48:26 +0900
committersefidel <contact@sefidel.net>2022-01-01 15:48:26 +0900
commitc6c0fdc2fc7742e2ecc2ad735efe80c99018dfa8 (patch)
tree32102cdf8875360522dd63f0328e53e51e8dab61 /home/modules/profiles/browsing/default.nix
parent3bdf459eccc217a649c52aaa2be21d9505215d73 (diff)
downloadnixrc-c6c0fdc2fc7742e2ecc2ad735efe80c99018dfa8.tar.gz
nixrc-c6c0fdc2fc7742e2ecc2ad735efe80c99018dfa8.zip
home/browser: add qutebrowser
Diffstat (limited to 'home/modules/profiles/browsing/default.nix')
-rw-r--r--home/modules/profiles/browsing/default.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/home/modules/profiles/browsing/default.nix b/home/modules/profiles/browsing/default.nix
index 45f0ed5..fedad6f 100644
--- a/home/modules/profiles/browsing/default.nix
+++ b/home/modules/profiles/browsing/default.nix
@@ -8,6 +8,23 @@ in
       };
 
     config = lib.mkIf cfg.enable {
-      home.packages = with pkgs; [ firefox lynx ];
+      home.packages = with pkgs; [ firefox-wayland lynx ];
+
+      programs.qutebrowser = {
+        enable = true;
+
+        searchEngines = {
+          g = "https://www.google.com/search?hl=en&q={}";
+          nw = "https://nixos.wiki/index.php?search={}";
+          no = "https://search.nixos.org/options?channel=unstable&from=0size=50&sort=relevance&type=packages&query={}";
+        };
+
+        quickmarks = {
+          github = "https://github.com";
+          sourcehut = "https://sr.ht";
+        };
+
+        settings = import ./qutebrowser-settings.nix;
+      };
     };
   }