about summary refs log tree commit diff
path: root/home/modules/profiles/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2021-12-28 01:11:25 +0900
committersefidel <contact@sefidel.net>2021-12-28 01:12:48 +0900
commit56992b8c945d497a623fe693847c91235be1ae02 (patch)
tree102ff8c8872d7e14ce3e3dba69bf16685374504e /home/modules/profiles/default.nix
downloadnixrc-56992b8c945d497a623fe693847c91235be1ae02.tar.gz
nixrc-56992b8c945d497a623fe693847c91235be1ae02.zip
initial commit
Diffstat (limited to 'home/modules/profiles/default.nix')
-rw-r--r--home/modules/profiles/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/modules/profiles/default.nix b/home/modules/profiles/default.nix
new file mode 100644
index 0000000..1fa2960
--- /dev/null
+++ b/home/modules/profiles/default.nix
@@ -0,0 +1,13 @@
+{ config, lib, ... }:
+let
+  profileEnabler =
+    let
+      reducer = l: r: { "${r}".enable = true; } // l;
+    in
+    builtins.foldl' reducer { } config.activeProfiles;
+in
+  {
+    options.activeProfiles = lib.mkOption { type = lib.types.listOf lib.types.str; };
+
+    config.profiles = profileEnabler;
+  }