about summary refs log tree commit diff
path: root/home/modules/profiles/research/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-04 14:52:57 +0900
committersefidel <contact@sefidel.net>2022-01-04 14:59:20 +0900
commit1bf8f5e3645e561da4feef950bd2f6dc5d649856 (patch)
treebcefffdd86ad87a12992aff99a9df70bad5e9dcd /home/modules/profiles/research/default.nix
parentcab97932e0b6d0ccef5e5429e9d26f0c45c307dd (diff)
downloadnixrc-1bf8f5e3645e561da4feef950bd2f6dc5d649856.tar.gz
nixrc-1bf8f5e3645e561da4feef950bd2f6dc5d649856.zip
home/modules: re-categorize profiles
Diffstat (limited to 'home/modules/profiles/research/default.nix')
-rw-r--r--home/modules/profiles/research/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/home/modules/profiles/research/default.nix b/home/modules/profiles/research/default.nix
new file mode 100644
index 0000000..5741400
--- /dev/null
+++ b/home/modules/profiles/research/default.nix
@@ -0,0 +1,14 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.research;
+in
+{
+  options.profiles.research = {
+    enable = lib.mkEnableOption
+      "A profile that enables the system to be used for researching various topics.";
+  };
+
+  config = lib.mkIf cfg.enable {
+    home.packages = with pkgs; [ obsidian ];
+    nixpkgs.allowedUnfree = [ "obsidian" ];
+  };
+}