about summary refs log tree commit diff
path: root/home/profiles/communication/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-03-03 21:27:48 +0900
committersefidel <contact@sefidel.net>2023-03-03 21:46:27 +0900
commitc3aeed28fb336274a593e84f0f9d655f7a9ed7ea (patch)
treed35c00f2e07a6adab8f8ae052c53d67a7bdb20a2 /home/profiles/communication/default.nix
parent642d0a35be463db007b239ddcde86bdea827907f (diff)
downloadnixrc-c3aeed28fb336274a593e84f0f9d655f7a9ed7ea.tar.gz
nixrc-c3aeed28fb336274a593e84f0f9d655f7a9ed7ea.zip
feat(home/communication): fix mbsync-oneshot
Diffstat (limited to 'home/profiles/communication/default.nix')
-rw-r--r--home/profiles/communication/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/home/profiles/communication/default.nix b/home/profiles/communication/default.nix
index 82664b3..3750013 100644
--- a/home/profiles/communication/default.nix
+++ b/home/profiles/communication/default.nix
@@ -44,9 +44,6 @@ in
             create = "maildir";
             remove = "none";
             expunge = "both";
-
-            extraConfig.account.SSLType = "IMAPS";
-            extraConfig.account.SSLVersions = "TLSv1.2";
           };
 
           msmtp.enable = true;
@@ -266,9 +263,14 @@ in
         };
         Service = {
           Type = "oneshot";
-          ExecStart = "${mbsyncCmd} --all";
+          ExecStart = "${mbsyncCmd} -Va";
           RemainAfterExit = true;
           TimeoutStartSec = "5min";
+          Environment = "PATH=${lib.makeBinPath [
+            # passage dependencies
+            pkgs.util-linux
+            pkgs.coreutils
+          ]}";
         };
         Install.WantedBy = [ "default.target" ];
       };