about summary refs log tree commit diff
path: root/home/profiles/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-25 18:08:24 +0900
committersefidel <contact@sefidel.net>2022-01-25 18:08:24 +0900
commit4b442b85223bf4e718db5ca917c17e4446144eb1 (patch)
treed5b094c5e885c91ade246c7951ff0557d0c1dbe5 /home/profiles/default.nix
parent98c46799bdecbde72773b75dd7eeb4bfd846c871 (diff)
downloadnixrc-4b442b85223bf4e718db5ca917c17e4446144eb1.tar.gz
nixrc-4b442b85223bf4e718db5ca917c17e4446144eb1.zip
home: make populator more obvious
Diffstat (limited to 'home/profiles/default.nix')
-rw-r--r--home/profiles/default.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/home/profiles/default.nix b/home/profiles/default.nix
deleted file mode 100644
index af9d9a8..0000000
--- a/home/profiles/default.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-{ config, lib, ... }:
-let
-  profileEnabler =
-    let
-      reducer = l: r: { "${r}".enable = true; } // l;
-    in
-    builtins.foldl' reducer { } config.activeProfiles;
-in
-{
-  options.activeProfiles = lib.mkOption { type = lib.types.listOf lib.types.str; };
-
-  config.profiles = profileEnabler;
-}