about summary refs log tree commit diff
path: root/home/profiles/gui/config/dunst.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-08-10 15:28:03 +0900
committersefidel <contact@sefidel.net>2024-08-10 15:28:03 +0900
commit92392ee2c2188a5fc2d2f2f8c5221bf0f43374e6 (patch)
tree4c05a65c888199188ea1d2fe72cac0c52b5b9448 /home/profiles/gui/config/dunst.nix
parent8cd277d2f4cef9e14f074d4eb6a235610f839418 (diff)
downloadnixrc-92392ee2c2188a5fc2d2f2f8c5221bf0f43374e6.tar.gz
nixrc-92392ee2c2188a5fc2d2f2f8c5221bf0f43374e6.zip
feat(home/gui): replace dunst with mako
Diffstat (limited to 'home/profiles/gui/config/dunst.nix')
-rw-r--r--home/profiles/gui/config/dunst.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/home/profiles/gui/config/dunst.nix b/home/profiles/gui/config/dunst.nix
deleted file mode 100644
index f6e80b3..0000000
--- a/home/profiles/gui/config/dunst.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ config, neotheme }:
-
-with neotheme.colors;
-
-let
-  guiCfg = config.profiles.gui;
-in
-{
-  global = {
-    padding = 8;
-    width = "330";
-    origin = "top-right";
-    offset = "8x25";
-    notification_limit = 5;
-    frame_width = 2;
-    vertical_alignment = "center";
-    horizontal_padding = 8;
-    icon_position = "left";
-    corner_radius = 10;
-
-    markup = "full";
-    word_wrap = true;
-    show_indicators = false;
-    format = "<b>%s</b>\\n\\n%b";
-    font = "${guiCfg.font.name} ${toString guiCfg.font.size}";
-    frame_color = "#${color3}";
-    separator_color = "auto";
-    max_icon_size = 80;
-  };
-
-  urgency_low = {
-    foreground = "#${foreground}";
-    background = "#${background}";
-    frame_color = "#${color4}";
-    timeout = 4;
-  };
-
-  urgency_normal = {
-    foreground = "#${foreground}";
-    background = "#${background}";
-    frame_color = "#${color3}";
-    timeout = 8;
-  };
-
-  urgency_critical = {
-    foreground = "#${foreground}";
-    background = "#${background}";
-    frame_color = "#${color1}";
-  };
-}