about summary refs log tree commit diff
path: root/home/profiles/gui/config/foot.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-07-25 18:58:27 +0900
committersefidel <contact@sefidel.net>2023-07-25 18:58:27 +0900
commitec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16 (patch)
treee36c9348852f95d95040ed61f7ee7a2b4501ef89 /home/profiles/gui/config/foot.nix
parent6ccd70ae9afee4f9c98135502abca8f9d0f2b58d (diff)
downloadnixrc-ec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16.tar.gz
nixrc-ec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16.zip
feat(home): split gui from base
Diffstat (limited to 'home/profiles/gui/config/foot.nix')
-rw-r--r--home/profiles/gui/config/foot.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/home/profiles/gui/config/foot.nix b/home/profiles/gui/config/foot.nix
new file mode 100644
index 0000000..bcb3145
--- /dev/null
+++ b/home/profiles/gui/config/foot.nix
@@ -0,0 +1,37 @@
+{ neotheme }:
+
+with neotheme.colors;
+
+{
+  main = {
+    term = "foot";
+    font = "Dina:pixelsize=13,JetBrainsMono Nerd Font:pixelsize=12";
+    letter-spacing = 0;
+    line-height = 13;
+    dpi-aware = "yes";
+    pad = "16x16 center";
+  };
+
+  cursor.style = "beam";
+
+  colors = {
+    background = background;
+    foreground = foreground;
+    regular0 = color0;
+    regular1 = color1;
+    regular2 = color2;
+    regular3 = color3;
+    regular4 = color4;
+    regular5 = color5;
+    regular6 = color6;
+    regular7 = color7;
+    bright0 = bright0;
+    bright1 = bright1;
+    bright2 = bright2;
+    bright3 = bright3;
+    bright4 = bright4;
+    bright5 = bright5;
+    bright6 = bright6;
+    bright7 = bright7;
+  };
+}