about summary refs log tree commit diff
path: root/home/profiles/gui/config/sway.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-08-05 17:21:05 +0900
committersefidel <contact@sefidel.net>2023-08-05 17:27:48 +0900
commitd57cd657c9477f4514e93e5ff6c9dd85450d96ea (patch)
tree21fb0926aed0717d54d2950b2e109bcc44fc786d /home/profiles/gui/config/sway.nix
parent6d7289eab528a7acb7adcb1be98ab9c6e850dddf (diff)
downloadnixrc-d57cd657c9477f4514e93e5ff6c9dd85450d96ea.tar.gz
nixrc-d57cd657c9477f4514e93e5ff6c9dd85450d96ea.zip
feat(home/gui): start inputMethod on sway startup
Diffstat (limited to 'home/profiles/gui/config/sway.nix')
-rw-r--r--home/profiles/gui/config/sway.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/home/profiles/gui/config/sway.nix b/home/profiles/gui/config/sway.nix
index 5577baf..eb4248c 100644
--- a/home/profiles/gui/config/sway.nix
+++ b/home/profiles/gui/config/sway.nix
@@ -1,4 +1,4 @@
-{ pkgs, neotheme }:
+{ config, pkgs, neotheme }:
 
 with neotheme.colors;
 
@@ -8,6 +8,8 @@ with neotheme.colors;
 
   exec autotiling
 
+  exec ${config.i18n.inputMethod.enabled} # assume binary name == option name
+
   # set modifiers
   set $mod Mod4
   set $alt Mod1