about summary refs log tree commit diff
path: root/home/profiles/gui/config/waybar/style.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-07-25 18:58:27 +0900
committersefidel <contact@sefidel.net>2023-07-25 18:58:27 +0900
commitec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16 (patch)
treee36c9348852f95d95040ed61f7ee7a2b4501ef89 /home/profiles/gui/config/waybar/style.nix
parent6ccd70ae9afee4f9c98135502abca8f9d0f2b58d (diff)
downloadnixrc-ec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16.tar.gz
nixrc-ec647eecd447bfbbd8f7b6f2fe5bb65ebf9abf16.zip
feat(home): split gui from base
Diffstat (limited to 'home/profiles/gui/config/waybar/style.nix')
-rw-r--r--home/profiles/gui/config/waybar/style.nix80
1 files changed, 80 insertions, 0 deletions
diff --git a/home/profiles/gui/config/waybar/style.nix b/home/profiles/gui/config/waybar/style.nix
new file mode 100644
index 0000000..d8714ed
--- /dev/null
+++ b/home/profiles/gui/config/waybar/style.nix
@@ -0,0 +1,80 @@
+{ neotheme }:
+
+with neotheme.colors;
+
+''
+  * {
+    border: none;
+    border-radius: 0;
+    font-family: "Dina, JetBrainsMono Nerd Font";
+    font-size: 12px;
+    min-height: 0;
+  }
+
+  window#waybar {
+    background: #${background};
+    color: #${foreground};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  #workspaces button {
+    min-width: 0;
+    padding: 0 8px;
+    background: #${background};
+    color: #${foreground};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  #workspaces button.focused {
+    color: #${foreground};
+    background-color: #${alt0};
+  }
+
+  #workspaces button.urgent {
+    color: #${color1};
+  }
+
+  #workspaces button.persistent {
+    color: #${alt1};
+  }
+
+  #workspaces button:hover {
+    color: #${foreground};
+    background: #${alt1};
+    box-shadow: inherit;
+    text-shadow: inherit;
+  }
+
+  #clock,
+  #cpu,
+  #temperature,
+  #backlight,
+  #battery,
+  #network,
+  #memory,
+  #idle_inhibitor,
+  #language,
+  #pulseaudio,
+  #tray,
+  #mode,
+  #mpd {
+    padding: 0.2rem 0.6rem;
+    margin: 0 2px;
+    color: #${foreground};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  @keyframes blink {
+    to {
+      background-color: #${color4};
+      color: #${background};
+    }
+  }
+
+  #custom-separator {
+    color: #${alt1};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
+  }
+''