about summary refs log tree commit diff
path: root/home/profiles/messaging/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-18 23:07:49 +0900
committersefidel <contact@sefidel.net>2022-01-18 23:07:55 +0900
commit4c14c3d40295f3da5fcca5ae75aa570de70dbfd9 (patch)
tree5c4c0c1ee9560390d039b21ba0be292057f104ea /home/profiles/messaging/default.nix
parent4d2d42b9da48302ea64c5a1d9f01d0c0f540523e (diff)
downloadnixrc-4c14c3d40295f3da5fcca5ae75aa570de70dbfd9.tar.gz
nixrc-4c14c3d40295f3da5fcca5ae75aa570de70dbfd9.zip
home: prefer inputs/overlays
Diffstat (limited to 'home/profiles/messaging/default.nix')
-rw-r--r--home/profiles/messaging/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/home/profiles/messaging/default.nix b/home/profiles/messaging/default.nix
index 73a721f..a8b42fe 100644
--- a/home/profiles/messaging/default.nix
+++ b/home/profiles/messaging/default.nix
@@ -10,8 +10,14 @@ in
   };
 
   config = lib.mkIf cfg.enable {
-    home.packages = with pkgs; [ discord-canary aerc weechat element slack ];
+    home.packages = with pkgs; [
+      aerc
+      (discord-canary-openasar.override { waylandSupport = true; })
+      element
+      slack
+      weechat
+    ];
 
-    nixpkgs.allowedUnfree = [ "discord-canary" "slack" ];
+    nixpkgs.allowedUnfree = [ "slack" ];
   };
 }