about summary refs log tree commit diff
path: root/modules/cachix/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-02-10 07:20:19 +0900
committersefidel <contact@sefidel.net>2024-02-10 07:42:24 +0900
commit0972ea9754a695b51840c0e58ef7c68dafb7b70d (patch)
treea349f134db3c3a8ab30d2eb249f57b6d0cd79399 /modules/cachix/default.nix
parent5b20c2cd2d26554945b8f4c2cec27b36fdbe6f3d (diff)
downloadnixrc-0972ea9754a695b51840c0e58ef7c68dafb7b70d.tar.gz
nixrc-0972ea9754a695b51840c0e58ef7c68dafb7b70d.zip
feat(modules): cachix -> binary-cache
Diffstat (limited to 'modules/cachix/default.nix')
-rw-r--r--modules/cachix/default.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/modules/cachix/default.nix b/modules/cachix/default.nix
deleted file mode 100644
index 9dd55b5..0000000
--- a/modules/cachix/default.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
-  folder = ./caches;
-  toImport = name: value: folder + ("/" + name);
-  filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
-  imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
-in
-{
-  inherit imports;
-  nix.settings.substituters = [ "https://cache.nixos.org/" ];
-
-  environment.systemPackages = [ pkgs.cachix ];
-}