about summary refs log tree commit diff
path: root/modules/services/_template.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 16:22:40 +0900
committersefidel <contact@sefidel.net>2024-01-24 16:22:54 +0900
commited8578cb356c5e714df07a8c3f4717b1a342d9a7 (patch)
treecbfa84767744564548e208e4cca314b7c882370a /modules/services/_template.nix
parent32bba888a932416c11359f15caf50ef7c7297ce8 (diff)
downloadnixrc-ed8578cb356c5e714df07a8c3f4717b1a342d9a7.tar.gz
nixrc-ed8578cb356c5e714df07a8c3f4717b1a342d9a7.zip
feat(nixos/kanata): add blocky
Diffstat (limited to 'modules/services/_template.nix')
-rw-r--r--modules/services/_template.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/services/_template.nix b/modules/services/_template.nix
new file mode 100644
index 0000000..b56d34f
--- /dev/null
+++ b/modules/services/_template.nix
@@ -0,0 +1,23 @@
+{ config, lib, ... }:
+
+with lib;
+let
+  cfg = config.modules.containers._template;
+in
+{
+  options.modules.containers._template = {
+    enable = mkEnableOption "";
+  };
+
+  config = mkIf cfg.enable {
+    containers._template = {
+      autoStart = true;
+      ephemeral = true; # XXX: false if the container isn't stateless
+      privateNetwork = true;
+      # XXX: more network setup (IP) needed here
+      config = { config, pkgs, ...}: {
+        system.stateVersion = "24.05";
+      };
+    };
+  };
+}