about summary refs log tree commit diff
path: root/nixos/alpha/configuration.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-26 22:35:48 +0900
committersefidel <contact@sefidel.net>2022-01-26 22:40:42 +0900
commite9ca070fbaaac5b4114d384081e0722ab1025260 (patch)
treef67e52b8244c002a5925957cd7a2feed4e3068a4 /nixos/alpha/configuration.nix
parentf1e005ac85d36002fa240340a07d418b86cb377b (diff)
downloadnixrc-e9ca070fbaaac5b4114d384081e0722ab1025260.tar.gz
nixrc-e9ca070fbaaac5b4114d384081e0722ab1025260.zip
nixos/alpha: zfs
Diffstat (limited to 'nixos/alpha/configuration.nix')
-rw-r--r--nixos/alpha/configuration.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nixos/alpha/configuration.nix b/nixos/alpha/configuration.nix
index c42fef6..4151ef0 100644
--- a/nixos/alpha/configuration.nix
+++ b/nixos/alpha/configuration.nix
@@ -12,10 +12,16 @@
 
   boot.kernelPackages = pkgs.linuxPackages_xanmod;
   boot.kernelParams = [
+    "nohibernate"
     "nmi_watchdog=0"
     "systemd.watchdog-device/dev/watchdog"
   ];
 
+  boot.initrd.supportedFilesystems = [ "zfs" ];
+  boot.supportedFilesystems = [ "zfs" ];
+  boot.zfs.devNodes = "/dev/";
+  boot.zfs.enableUnstable = true;
+
   # GRUB bootloader
   boot.loader.efi.canTouchEfiVariables = true;
   boot.loader.grub = {
@@ -26,6 +32,7 @@
     configurationLimit = 10;
     device = "nodev";
     useOSProber = true;
+    copyKernels = true;
     extraEntries = ''
       menuentry "Reboot" {
         reboot
@@ -37,6 +44,8 @@
   };
 
   networking.hostName = "alpha";
+  networking.hostId = "641a7b10";
+
   networking.networkmanager.enable = true;
   networking.useDHCP = false;
   networking.firewall.enable = true;
@@ -68,6 +77,10 @@
 
   environment.systemPackages = with pkgs; [ gcc ];
 
+  services.zfs.trim.enable = true;
+  services.zfs.autoScrub.enable = true;
+  services.zfs.autoScrub.pools = [ "rpool" ];
+
   services.openssh.enable = true;
   services.openssh.passwordAuthentication = false;