about summary refs log tree commit diff
path: root/nixos/alpha/hardware-configuration.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-06-06 19:26:21 +0900
committersefidel <contact@sefidel.net>2022-06-06 19:26:21 +0900
commit7a8b716d572c1437f8522e3b5e08d6798f3a9eb9 (patch)
treef6548eed7cd5a171383d37be805702c6ff35cb33 /nixos/alpha/hardware-configuration.nix
parentb0c6f86d408ef5c84890ba55b5ded259f6127a73 (diff)
downloadnixrc-7a8b716d572c1437f8522e3b5e08d6798f3a9eb9.tar.gz
nixrc-7a8b716d572c1437f8522e3b5e08d6798f3a9eb9.zip
feat(nixos/alpha): system fixup
Diffstat (limited to 'nixos/alpha/hardware-configuration.nix')
-rw-r--r--nixos/alpha/hardware-configuration.nix39
1 files changed, 7 insertions, 32 deletions
diff --git a/nixos/alpha/hardware-configuration.nix b/nixos/alpha/hardware-configuration.nix
index 0d0593f..8636fad 100644
--- a/nixos/alpha/hardware-configuration.nix
+++ b/nixos/alpha/hardware-configuration.nix
@@ -10,52 +10,27 @@
   hardware.enableRedistributableFirmware = true;
 
   fileSystems."/" = {
-    device = "rpool/root/nixos";
+    device = "rpool/local/root";
     fsType = "zfs";
   };
 
   fileSystems."/boot" = {
-    device = "/dev/disk/by-uuid/55B4-0E38";
+    device = "/dev/disk/by-uuid/31C2-3406";
     fsType = "vfat";
   };
 
   fileSystems."/nix" = {
-    device = "rpool/root/nixos/nix";
-    fsType = "zfs";
-  };
-
-  fileSystems."/etc" = {
-    device = "rpool/root/nixos/etc";
-    fsType = "zfs";
-  };
-
-  fileSystems."/var" = {
-    device = "rpool/root/nixos/var";
-    fsType = "zfs";
-  };
-
-  fileSystems."/var/lib" = {
-    device = "rpool/root/nixos/var/lib";
-    fsType = "zfs";
-  };
-
-  fileSystems."/var/log" = {
-    device = "rpool/root/nixos/var/log";
-    fsType = "zfs";
-  };
-
-  fileSystems."/var/spool" = {
-    device = "rpool/root/nixos/var/spool";
+    device = "rpool/local/nix";
     fsType = "zfs";
   };
 
   fileSystems."/home" = {
-    device = "rpool/home";
+    device = "rpool/safe/home";
     fsType = "zfs";
   };
 
-  fileSystems."/home/zach" = {
-    device = "rpool/home/zach";
+  fileSystems."/persist" = {
+    device = "rpool/safe/persist";
     fsType = "zfs";
   };
 
@@ -64,7 +39,7 @@
     fsType = "ext4";
   };
 
-  swapDevices = [ ];
+  swapDevices = [ { device = "/dev/disk/by-uuid/ff8bd8d2-2b3b-495d-8865-9cd140dd1f54"; } ];
 
   nix.settings.max-jobs = lib.mkDefault 4;
   powerManagement.cpuFreqGovernor = lib.mkDefault "schedutil";