about summary refs log tree commit diff
path: root/nixos/cobalt/hardware-configuration.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-02-10 18:38:19 +0900
committersefidel <contact@sefidel.net>2023-02-10 18:38:45 +0900
commit0d28ac05f7ae524fe17a7a3485744e3ffa99ccb6 (patch)
treec1ab383a15c8705d99fe2f5e5a69373b3d951a4d /nixos/cobalt/hardware-configuration.nix
parent3a0ab37f75f127fa5a5746d4d741b0122ef7a8aa (diff)
downloadnixrc-0d28ac05f7ae524fe17a7a3485744e3ffa99ccb6.tar.gz
nixrc-0d28ac05f7ae524fe17a7a3485744e3ffa99ccb6.zip
feat(nixos): remove cobalt
Diffstat (limited to 'nixos/cobalt/hardware-configuration.nix')
-rw-r--r--nixos/cobalt/hardware-configuration.nix65
1 files changed, 0 insertions, 65 deletions
diff --git a/nixos/cobalt/hardware-configuration.nix b/nixos/cobalt/hardware-configuration.nix
deleted file mode 100644
index 95ecb96..0000000
--- a/nixos/cobalt/hardware-configuration.nix
+++ /dev/null
@@ -1,65 +0,0 @@
-# Do not modify this file!  It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations.  Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
-  imports =
-    [
-      (modulesPath + "/installer/scan/not-detected.nix")
-    ];
-
-  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "sd_mod" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-intel" ];
-  boot.extraModulePackages = [ ];
-
-  fileSystems."/" =
-    {
-      device = "rpool/local/root";
-      fsType = "zfs";
-    };
-
-  fileSystems."/boot" =
-    {
-      device = "/dev/disk/by-uuid/445A-0C55";
-      fsType = "vfat";
-    };
-
-  fileSystems."/boot-fallback" =
-    {
-      device = "/dev/disk/by-uuid/445C-198F";
-      fsType = "vfat";
-    };
-
-  fileSystems."/nix" =
-    {
-      device = "rpool/local/nix";
-      fsType = "zfs";
-    };
-
-  fileSystems."/home" =
-    {
-      device = "rpool/safe/home";
-      fsType = "zfs";
-    };
-
-  fileSystems."/persist" =
-    {
-      device = "rpool/safe/persist";
-      fsType = "zfs";
-    };
-
-  swapDevices = [ ];
-
-  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
-  # (the default) this is the recommended approach. When using systemd-networkd it's
-  # still possible to use this option, but it's recommended to use it in conjunction
-  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
-  networking.useDHCP = lib.mkDefault false;
-  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
-
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}