about summary refs log tree commit diff
path: root/nixos/cobalt/services/soju.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-02-06 18:08:33 +0900
committersefidel <contact@sefidel.net>2023-02-06 18:08:33 +0900
commit2788edf8f6ddc0a5ccd141db51321cd21abb5adf (patch)
treecbca719739f3eeef32dd47cb9d0fa823f09c4915 /nixos/cobalt/services/soju.nix
parentbdf36408a71b1b3993a9552637d86495cb677b86 (diff)
downloadnixrc-2788edf8f6ddc0a5ccd141db51321cd21abb5adf.tar.gz
nixrc-2788edf8f6ddc0a5ccd141db51321cd21abb5adf.zip
feat: merge colmena to nixos
Diffstat (limited to 'nixos/cobalt/services/soju.nix')
-rw-r--r--nixos/cobalt/services/soju.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/nixos/cobalt/services/soju.nix b/nixos/cobalt/services/soju.nix
new file mode 100644
index 0000000..c150879
--- /dev/null
+++ b/nixos/cobalt/services/soju.nix
@@ -0,0 +1,26 @@
+{
+  services.soju = {
+    enable = true;
+    extraGroups = [ "acme" ];
+    hostName = "cobalt.sefidel.com";
+    listen = [
+      ":6697"
+    ];
+    tlsCertificate = "/var/lib/acme/sefidel.com/cert.pem";
+    tlsCertificateKey = "/var/lib/acme/sefidel.com/key.pem";
+  };
+
+  networking.firewall.allowedTCPPorts = [ 6697 ];
+
+  environment.persistence."/persist".directories = [
+    "/var/lib/private/soju"
+  ];
+
+  # TODO: remove this once merged
+  disabledModules = [ "services/networking/soju.nix" ];
+
+  imports = [
+    ./acme.nix
+    ../modules/soju.nix
+  ];
+}