about summary refs log tree commit diff
path: root/nixos/colmena.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-02-06 18:08:33 +0900
committersefidel <contact@sefidel.net>2023-02-06 18:08:33 +0900
commit2788edf8f6ddc0a5ccd141db51321cd21abb5adf (patch)
treecbca719739f3eeef32dd47cb9d0fa823f09c4915 /nixos/colmena.nix
parentbdf36408a71b1b3993a9552637d86495cb677b86 (diff)
downloadnixrc-2788edf8f6ddc0a5ccd141db51321cd21abb5adf.tar.gz
nixrc-2788edf8f6ddc0a5ccd141db51321cd21abb5adf.zip
feat: merge colmena to nixos
Diffstat (limited to 'nixos/colmena.nix')
-rw-r--r--nixos/colmena.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/nixos/colmena.nix b/nixos/colmena.nix
new file mode 100644
index 0000000..99945e6
--- /dev/null
+++ b/nixos/colmena.nix
@@ -0,0 +1,28 @@
+{ self, unstable, unstable-small, ... } @ inputs:
+
+{
+  meta = {
+    nixpkgs = import unstable {
+      system = "x86_64-linux";
+    };
+  };
+
+  defaults = { pkgs, ... }: {
+    environment.systemPackages = with pkgs; [
+      curl
+      vim
+    ];
+  };
+
+  cobalt = self.lib.mkColmena {
+    name = "cobalt";
+    system = "x86_64-linux";
+    inputs = inputs;
+    deployment = {
+      targetHost = "cobalt.sefidel.com";
+      targetPort = 22;
+      targetUser = "root";
+    };
+    time.timeZone = "UTC";
+  };
+}