about summary refs log tree commit diff
path: root/nixos/configurations/alpha.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
committersefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
commit7a372ed81256ce5d6aa608be9bebe173ab4e042e (patch)
tree29c7ee0a316ae0dc21ce3fe22342ec2c36ee0f4c /nixos/configurations/alpha.nix
parent2bdc141bebd35cc38396271c42b23b6f89d032a0 (diff)
downloadnixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.tar.gz
nixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.zip
project: rewrite
Diffstat (limited to 'nixos/configurations/alpha.nix')
-rw-r--r--nixos/configurations/alpha.nix143
1 files changed, 0 insertions, 143 deletions
diff --git a/nixos/configurations/alpha.nix b/nixos/configurations/alpha.nix
deleted file mode 100644
index d7fe368..0000000
--- a/nixos/configurations/alpha.nix
+++ /dev/null
@@ -1,143 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{
-  imports = [ ];
-
-  security = {
-    protectKernelImage = true;
-    rtkit.enable = true;
-    sudo.wheelNeedsPassword = false;
-  };
-
-  boot.kernelPackages = pkgs.linuxPackages_xanmod;
-  boot.kernelParams = [
-    "nmi_watchdog=0"
-    "systemd.watchdog-device/dev/watchdog"
-  ];
-
-  # GRUB bootloader
-  boot.loader.efi.canTouchEfiVariables = true;
-  boot.loader.grub = {
-    enable = true;
-    version = 2;
-
-    efiSupport = true;
-    configurationLimit = 10;
-    device = "nodev";
-    useOSProber = true;
-    # device = "/dev/disk/by-uuid/7905-2E41";
-    extraEntries = ''
-      menuentry "Reboot" {
-        reboot
-      }
-      menuentry "Shutdown" {
-        halt
-      }
-    '';
-  };
-
-  networking.networkmanager.enable = true;
-  networking.useDHCP = false;
-  networking.firewall.enable = true;
-
-  i18n.defaultLocale = "en_US.UTF-8";
-
-  console.font = "Lat2-Terminus16";
-  console.keyMap = "us";
-
-  time.timeZone = "Asia/Seoul";
-
-  environment.systemPackages = with pkgs; [ gcc ];
-
-  services.openssh.enable = true;
-
-  sound.enable = true;
-  services.pipewire = {
-    enable = true;
-    alsa.enable = true;
-    alsa.support32Bit = true;
-    pulse.enable = true;
-  };
-
-  hardware.bluetooth.enable = true;
-
-  services.greetd = {
-    enable = true;
-
-    settings.default_session.command = "${pkgs.greetd.tuigreet}/bin/tuigreet -t -c sway";
-  };
-
-  # https://github.com/apognu/tuigreet/issues/17
-  systemd.services.greetd.unitConfig.After = lib.mkOverride 0 [ "multi-user.target" ];
-
-  services.journald.extraConfig = lib.mkForce "";
-
-  # HACK: fix treesitter
-  systemd.tmpfiles.rules = [
-    "L+ /lib/libstdc++.so.6 - - - - ${pkgs.stdenv.cc.cc.lib}/lib/libstdc++.so.6"
-  ];
-
-  systemd.extraConfig = "RebootWatchdogSec=5";
-
-  programs = {
-    sway = {
-      enable = true;
-      wrapperFeatures.gtk = true;
-
-      extraPackages = with pkgs; [
-        autotiling
-        alacritty
-        swaylock
-        swayidle
-        swaybg
-        wayland-utils
-        wl-clipboard
-        grim
-        slurp
-        sway-contrib.grimshot
-        waybar
-        bemenu
-        qt5.qtwayland
-        xdg_utils
-      ];
-    };
-
-    zsh.enable = true;
-    zsh.enableCompletion = false;
-  };
-
-  hardware.opengl.enable = true;
-  hardware.opengl.driSupport32Bit = true;
-  hardware.opengl.extraPackages = with pkgs; [ vaapiVdpau libvdpau-va-gl ];
-
-  xdg.portal = {
-    enable = true;
-    gtkUsePortal = true;
-    extraPortals = with pkgs; [
-      xdg-desktop-portal-gtk
-      xdg-desktop-portal-wlr
-    ];
-  };
-
-  virtualisation.libvirtd.enable = true;
-
-  users.users = {
-    boopy = {
-      isNormalUser = true;
-      shell = pkgs.zsh;
-
-      extraGroups = [
-        "wheel"
-        "audio"
-        "networkmanager"
-        "libvirtd"
-      ];
-    };
-  };
-
-  # This value determines the NixOS release with which your system is to be
-  # compatible, in order to avoid breaking some software such as database
-  # servers. You should change this only after NixOS release notes say you
-  # should.
-  system.stateVersion = "22.05"; # Did you read the comment?
-}