about summary refs log tree commit diff
path: root/nixos/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
committersefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
commit7a372ed81256ce5d6aa608be9bebe173ab4e042e (patch)
tree29c7ee0a316ae0dc21ce3fe22342ec2c36ee0f4c /nixos/default.nix
parent2bdc141bebd35cc38396271c42b23b6f89d032a0 (diff)
downloadnixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.tar.gz
nixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.zip
project: rewrite
Diffstat (limited to 'nixos/default.nix')
-rw-r--r--nixos/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nixos/default.nix b/nixos/default.nix
new file mode 100644
index 0000000..211f3d5
--- /dev/null
+++ b/nixos/default.nix
@@ -0,0 +1,14 @@
+{ self, nixpkgs, ... } @ inputs:
+
+{
+  alpha = self.lib.mkSystem {
+    name = "alpha";
+    nixpkgs = nixpkgs;
+    extraModules = [
+      inputs.sops-nix.nixosModules.sops
+      ./modules/security.nix
+      ./modules/cachix
+      ./alpha/configuration.nix
+    ];
+  };
+}