about summary refs log tree commit diff
path: root/nixos/kanata/hardware-configuration.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-23 01:00:54 +0900
committersefidel <contact@sefidel.net>2024-01-23 01:05:05 +0900
commit052f5877c66560586f6945f14f8224588bb61c49 (patch)
tree85d4e1d650a40986768df183df8b3811146985b2 /nixos/kanata/hardware-configuration.nix
parentb2d4dbd14281fb90eb9230738710602dd60f645e (diff)
downloadnixrc-052f5877c66560586f6945f14f8224588bb61c49.tar.gz
nixrc-052f5877c66560586f6945f14f8224588bb61c49.zip
feat(nixos): add kanata
Diffstat (limited to 'nixos/kanata/hardware-configuration.nix')
-rw-r--r--nixos/kanata/hardware-configuration.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/nixos/kanata/hardware-configuration.nix b/nixos/kanata/hardware-configuration.nix
new file mode 100644
index 0000000..b81b08d
--- /dev/null
+++ b/nixos/kanata/hardware-configuration.nix
@@ -0,0 +1,56 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "mpt3sas" "usbhid" "usb_storage" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-amd" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "rpool/local/root";
+      fsType = "zfs";
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/7141-F8DA";
+      fsType = "vfat";
+    };
+
+  fileSystems."/nix" =
+    { device = "rpool/local/nix";
+      fsType = "zfs";
+    };
+
+  fileSystems."/home" =
+    { device = "rpool/safe/home";
+      fsType = "zfs";
+    };
+
+  fileSystems."/persist" =
+    { device = "rpool/safe/persist";
+      fsType = "zfs";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/c092b7a3-813c-4be7-9730-45d9426f524c"; }
+    ];
+
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  # TODO FIXME(sefidel): uncomment
+  # networking.useDHCP = lib.mkDefault true;
+  networking.useDHCP = lib.mkForce true;
+  # networking.interfaces.enp4s0.useDHCP = lib.mkDefault true;
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}