about summary refs log tree commit diff
path: root/packages/linux.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-09-09 17:49:03 +0900
committersefidel <contact@sefidel.net>2022-09-09 21:32:31 +0900
commit9e6145c031b47fc37398b80dec1b4dfc0cfb5183 (patch)
treef27e3c50a0c25223931e7057616e456432007de9 /packages/linux.nix
parent9e311725d4f6c68284e3999c01735ebe3665a14d (diff)
downloadnixrc-9e6145c031b47fc37398b80dec1b4dfc0cfb5183.tar.gz
nixrc-9e6145c031b47fc37398b80dec1b4dfc0cfb5183.zip
milestone: darwin!
feat(darwin/kompakt)!: support darwin

chore: reformat

feat(home/o32): manage neovim

feat(home/development): fix haskell lsp version mismatch

feat(darwin/*): stabilise
Diffstat (limited to 'packages/linux.nix')
-rw-r--r--packages/linux.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/linux.nix b/packages/linux.nix
new file mode 100644
index 0000000..89cd404
--- /dev/null
+++ b/packages/linux.nix
@@ -0,0 +1,15 @@
+{ self, neovim, ... } @ inputs:
+
+let
+  pkgs = inputs.unstable.legacyPackages.x86_64-linux;
+  vscode-lldb = pkgs.vscode-extensions.vadimcn.vscode-lldb;
+in
+
+{
+  "neovim" = neovim.packages.x86_64-linux.neovim;
+  # "codelldb" = pkgs.writeScriptBin "codelldb" ''
+  # ${vscode-lldb}/share/vscode/extensions/vadimcn.vscode-lldb/adapter/.codelldb-wrapped_ \
+  # --liblldb ${vscode-lldb}/share/vscode/extensions/vadimcn.vscode-lldb/lldb/lib/liblldb.so $@
+  # '';
+  "athens" = pkgs.callPackage ./athens.nix { };
+}