about summary refs log tree commit diff
path: root/packages/phocus/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-31 09:17:46 +0900
committersefidel <contact@sefidel.net>2022-01-31 09:17:46 +0900
commit74c5c6f717c47f92a85b46689913bb6889a9c42e (patch)
tree308ba64e2cdd70a7bf7fabb74328b6fba26fca77 /packages/phocus/default.nix
parentfb57683418e7ee41573c8ba4f3179ba8ed8b7124 (diff)
downloadnixrc-74c5c6f717c47f92a85b46689913bb6889a9c42e.tar.gz
nixrc-74c5c6f717c47f92a85b46689913bb6889a9c42e.zip
flakes: bump flakes
Diffstat (limited to 'packages/phocus/default.nix')
-rw-r--r--packages/phocus/default.nix60
1 files changed, 0 insertions, 60 deletions
diff --git a/packages/phocus/default.nix b/packages/phocus/default.nix
deleted file mode 100644
index 662a199..0000000
--- a/packages/phocus/default.nix
+++ /dev/null
@@ -1,60 +0,0 @@
-{ lib, stdenvNoCC, sass, src }:
-
-let
-  # Iceberg theme with nightlamp bg
-  colors = {
-    base00 = "18191f";
-    base01 = "17171b";
-    base02 = "c9cdd7";
-    base03 = "6b7089";
-    base04 = "090a10";
-    base05 = "c6c8d1";
-    base06 = "d0d2db";
-    base07 = "27282e";
-    base08 = "e27878";
-    base09 = "e2a478";
-    base0A = "e9b189";
-    base0B = "b4be82";
-    base0C = "89b8c2";
-    base0D = "84a0c6";
-    base0E = "a093c7";
-    base0F = "a0a0d3";
-  };
-in
-stdenvNoCC.mkDerivation rec {
-  pname = "phocus";
-  version = "unstable-2021-05-05";
-
-  inherit src;
-
-  patchPhase = with colors; ''
-    runHook prePatch
-    substituteInPlace scss/gtk-3.0/_colors.scss \
-      --replace 16161c ${base00} \
-      --replace 232530 ${base01} \
-      --replace 2e303e ${base03} \
-      --replace e95678 ${base08} \
-      --replace f09383 ${base09} \
-      --replace fab795 ${base0A} \
-      --replace 29d398 ${base0B} \
-      --replace 1eb980 ${base0B} \
-      --replace 26bbd9 ${base0D} \
-      --replace ee64ae ${base0E} \
-      --replace ec6a88 ${base08} \
-      --replace fdf0ed ${base05} \
-      --replace aabbcc ${base0D} \
-      --replace ccbbaa ${base0E}
-    runHook postPatch
-  '';
-
-  nativeBuildInputs = [ sass ];
-
-  installFlags = [ "DESTDIR=$(out)" "PREFIX=" ];
-
-  meta = with lib; {
-    description = "phocus with nightlamp (iceberg variant) theme";
-    homepage = "https://git.sr.ht/~boppy/phocus";
-    license = [ licenses.mit ];
-    maintainers = with maintainers; [ boppyt ];
-  };
-}