about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/home/default.nix b/home/default.nix
index eb52fb5..2bb23a1 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -66,6 +66,38 @@
     version = "23.11";
   };
 
+  "remirin@delta" = self.lib.mkHome {
+    username = "remirin";
+    hostname = "delta";
+    homeDirectory = "/Users/remirin";
+    pkgs = import unstable {
+      system = "aarch64-apple-darwin";
+      overlays = with inputs; [
+        rust.overlays.default
+        neovim-nightly.overlays.default
+        nur.overlays.default
+      ];
+    };
+
+    extraModules = [
+      ./profiles/populate.nix
+      ./profiles/base
+      ./profiles/darwin
+      ./profiles/browsing
+      ./profiles/development
+      ./profiles/communication
+      ./profiles/multimedia
+      ./profiles/creative
+      ./profiles/research
+      ./profiles/security
+
+      inputs.mac-app-util.homeManagerModules.default
+      inputs.sops-nix.homeManagerModules.sops
+    ];
+
+    version = "25.05";
+  };
+
   "sefidel@cobalt" = self.lib.mkHome {
     username = "sefidel";
     hostname = "cobalt";