about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/default.nix b/home/default.nix
index f8ce8fe..5c7f857 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -18,4 +18,19 @@
 
     version = "22.05";
   };
+
+  "o32@kompakt" = self.lib.mkHome {
+    username = "o32";
+    hostname = "kompakt";
+    pkgs = import unstable { system = "aarch64-darwin"; overlays = with inputs; [ rust.overlays.default (import ../darwin/darwin-x86.nix { inherit unstable; }) ]; };
+
+    extraModules = [
+      ./profiles/populate.nix
+      ./profiles/base-darwin
+      ./profiles/development
+      ./profiles/messaging
+    ];
+
+    version = "22.05";
+  };
 }