about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/waybar-settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/base/config/waybar-settings.nix')
-rw-r--r--home/modules/profiles/base/config/waybar-settings.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/home/modules/profiles/base/config/waybar-settings.nix b/home/modules/profiles/base/config/waybar-settings.nix
new file mode 100644
index 0000000..e208895
--- /dev/null
+++ b/home/modules/profiles/base/config/waybar-settings.nix
@@ -0,0 +1,68 @@
+{
+  layer = "bottom";
+  position = "top";
+  height = 17;
+  modules-left = [ "sway/workspaces" "sway/language" "cpu" "memory" ];
+  modules-center = [ "clock" ];
+  modules-right = [ "custom/weather" "pulseaudio" "network" ];
+
+  modules = {
+    "sway/workspaces" = {
+      all-outputs = true;
+
+      persistent_workspaces = {
+        "α" = [ ];
+        "β" = [ ];
+        "γ" = [ ];
+        "δ" = [ ];
+        "ε" = [ ];
+        "ζ" = [ ];
+        "η" = [ ];
+        "θ" = [ ];
+        "ι" = [ ];
+        "κ" = [ ];
+      };
+    };
+
+    "sway/language" = {
+      format = " {long}";
+    };
+
+    "clock" = {
+      interval = 10;
+      format = "{:  %m/%d/%Y %I:%M %p}";
+    };
+
+    "cpu" = {
+      interval = 5;
+      format = " {usage:3}%";
+    };
+
+    "custom/weather" = {
+      format = "  {}";
+      exec = "curl 'wttr.in/?format='%t+-+%x+%C++%w'&M'";
+      interval = 3600;
+    };
+
+    "network" = {
+      interval = 5;
+      interface = "enp4s0";
+      format = " {ifname}";
+      format-wifi = " {essid}  {bandwidthUpBits}  {bandwidthDownBits}";
+      format-ethernet = "   {bandwidthUpBits:>}  {bandwidthDownBits:>}";
+      format-disconnected = " Disconnected";
+      max-length = 50;
+    };
+
+    "pulseaudio" = {
+      format = "{icon} {volume}%";
+      format-muted = "ﱝ  Muted";
+      format-icons.default = [ " " " " " " ];
+    };
+
+    "memory" = {
+      interval = 5;
+      format = " {used:0.1f}G / {total:0.1f}G ({percentage:3}%)";
+    };
+  };
+}