about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/waybar-style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/base/config/waybar-style.nix')
-rw-r--r--home/modules/profiles/base/config/waybar-style.nix38
1 files changed, 27 insertions, 11 deletions
diff --git a/home/modules/profiles/base/config/waybar-style.nix b/home/modules/profiles/base/config/waybar-style.nix
index 11c0d7d..e3f30f6 100644
--- a/home/modules/profiles/base/config/waybar-style.nix
+++ b/home/modules/profiles/base/config/waybar-style.nix
@@ -14,22 +14,32 @@ with neotheme.colors;
   window#waybar {
     background: #${background};
     color: #${foreground};
-    padding: 10px;
+    border-bottom: 1px solid #${bright0};
   }
 
   #workspaces button {
     padding: 0 8px;
-    background: #${color4};
-    color: #${background};
-    border-bottom: 3px solid rgba (255, 255, 255, .2);
+    background: #${background};
+    color: #${foreground};
+    border-bottom: 1px solid #${bright0};
   }
 
   #workspaces button.focused {
-    background-color: #${color4};
-    border-bottom: 3px solid #${background};
+    color: #${foreground};
+    background-color: #${bright0};
+  }
+
+  #workspaces button.urgent {
+    color: #${color1};
+  }
+
+  #workspaces button.persistent {
+    color: #${alt1};
   }
 
   #workspaces button:hover {
+    color: #${foreground};
+    background: #${alt1};
     box-shadow: inherit;
     text-shadow: inherit;
   }
@@ -45,11 +55,11 @@ with neotheme.colors;
   #tray,
   #mode,
   #mpd {
-    padding: 0 10px;
-    margin: 0 4px;
-    color: #${background};
-    background-color: #${color4};
-    border-bottom: 3px solid rgba (255, 255, 255, .2);
+    padding: 0.2rem 0.6rem;
+    margin: 0 2px;
+    color: #${foreground};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
   }
 
   @keyframes blink {
@@ -58,4 +68,10 @@ with neotheme.colors;
       color: #${background};
     }
   }
+
+  #custom-seperator {
+    color: #${bright0};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
+  }
 ''