about summary refs log tree commit diff
path: root/home/modules/profiles/messaging/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/messaging/default.nix')
-rw-r--r--home/modules/profiles/messaging/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/home/modules/profiles/messaging/default.nix b/home/modules/profiles/messaging/default.nix
new file mode 100644
index 0000000..1bdc873
--- /dev/null
+++ b/home/modules/profiles/messaging/default.nix
@@ -0,0 +1,14 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.messaging;
+in
+  {
+    options.profiles.messaging = {
+      enable = lib.mkEnableOption
+        "A profile that enables the system to communicate via internet.";
+      };
+
+    config = lib.mkIf cfg.enable {
+      home.packages = with pkgs; [ discord-canary aerc weechat element slack ];
+      nixpkgs.allowedUnfree = [ "discord-canary" "slack" ];
+    };
+  }