about summary refs log tree commit diff
path: root/home/profiles/base/config/dunst.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/config/dunst.nix')
-rw-r--r--home/profiles/base/config/dunst.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/home/profiles/base/config/dunst.nix b/home/profiles/base/config/dunst.nix
new file mode 100644
index 0000000..60ed15f
--- /dev/null
+++ b/home/profiles/base/config/dunst.nix
@@ -0,0 +1,47 @@
+{ neotheme }:
+
+with neotheme.colors;
+{
+  global = {
+    padding = 8;
+    width = "330";
+    height = "500";
+    origin = "top-right";
+    offset = "8x25";
+    notification_limit = 5;
+    frame_width = 2;
+    vertical_alignment = "center";
+    horizontal_padding = 8;
+    icon_position = "left";
+    corner_radius = 10;
+
+    markup = "full";
+    word_wrap = true;
+    show_indicators = false;
+    format = "<b>%s</b>\\n\\n%b";
+    font = "Dina 10";
+    frame_color = "#${color3}";
+    separator_color = "auto";
+    max_icon_size = 80;
+  };
+
+  urgency_low = {
+    foreground = "#${foreground}";
+    background = "#${background}";
+    frame_color = "#${color4}";
+    timeout = 4;
+  };
+
+  urgency_normal = {
+    foreground = "#${foreground}";
+    background = "#${background}";
+    frame_color = "#${color3}";
+    timeout = 8;
+  };
+
+  urgency_critical = {
+    foreground = "#${foreground}";
+    background = "#${background}";
+    frame_color = "#${color1}";
+  };
+}