about summary refs log tree commit diff
path: root/home/profiles/base/config/waybar-settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/config/waybar-settings.nix')
-rw-r--r--home/profiles/base/config/waybar-settings.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/home/profiles/base/config/waybar-settings.nix b/home/profiles/base/config/waybar-settings.nix
new file mode 100644
index 0000000..089fefb
--- /dev/null
+++ b/home/profiles/base/config/waybar-settings.nix
@@ -0,0 +1,54 @@
+{ neotheme }:
+
+with neotheme.colors;
+{
+  layer = "bottom";
+  position = "top";
+  height = 21;
+  modules-left = [ "pulseaudio" "custom/seperator" "cpu" "custom/seperator" "memory" ];
+  modules-center = [ "sway/workspaces" ];
+  modules-right = [ "clock" ];
+
+  "sway/workspaces" = {
+    all-outputs = true;
+    persistent_workspaces = {
+      "α" = [ ];
+      "β" = [ ];
+      "γ" = [ ];
+      "δ" = [ ];
+      "ε" = [ ];
+      "ζ" = [ ];
+      "η" = [ ];
+      "θ" = [ ];
+      "ι" = [ ];
+      "κ" = [ ];
+    };
+  };
+
+  "clock" = {
+    interval = 10;
+    format = "<span foreground='#${color5}'></span> {:%A, %b %d %H:%M}";
+  };
+
+  "cpu" = {
+    interval = 5;
+    format = "<span foreground='#${color2}'></span> {usage:3}%";
+  };
+
+  "pulseaudio" = {
+    format = "<span foreground='#${color4}'>{icon}</span> {volume}%";
+    format-muted = "ﱝ  Muted";
+    format-icons.default = [ " " " " " " ];
+  };
+
+  "memory" = {
+    interval = 5;
+    format = "<span foreground='#${color3}'>﬙</span> {used:0.2f}GiB";
+  };
+
+  "custom/seperator" = {
+    format = "|";
+    interval = "once";
+    tooltip = false;
+  };
+}