about summary refs log tree commit diff
path: root/home/profiles/base/config/waybar-style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/config/waybar-style.nix')
-rw-r--r--home/profiles/base/config/waybar-style.nix77
1 files changed, 77 insertions, 0 deletions
diff --git a/home/profiles/base/config/waybar-style.nix b/home/profiles/base/config/waybar-style.nix
new file mode 100644
index 0000000..0901a6a
--- /dev/null
+++ b/home/profiles/base/config/waybar-style.nix
@@ -0,0 +1,77 @@
+{ neotheme }:
+
+with neotheme.colors;
+
+''
+  * {
+    border: none;
+    border-radius: 0;
+    font-family: "JetBrainsMono Nerd Font";
+    font-size: 14px;
+    min-height: 0;
+  }
+
+  window#waybar {
+    background: #${background};
+    color: #${foreground};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  #workspaces button {
+    padding: 0 8px;
+    background: #${background};
+    color: #${foreground};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  #workspaces button.focused {
+    color: #${foreground};
+    background-color: #${bright0};
+  }
+
+  #workspaces button.urgent {
+    color: #${color1};
+  }
+
+  #workspaces button.persistent {
+    color: #${alt1};
+  }
+
+  #workspaces button:hover {
+    color: #${foreground};
+    background: #${alt1};
+    box-shadow: inherit;
+    text-shadow: inherit;
+  }
+
+  #clock,
+  #cpu,
+  #temperature,
+  #backlight,
+  #network,
+  #memory,
+  #language,
+  #pulseaudio,
+  #tray,
+  #mode,
+  #mpd {
+    padding: 0.2rem 0.6rem;
+    margin: 0 2px;
+    color: #${foreground};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
+  }
+
+  @keyframes blink {
+    to {
+      background-color: #${color4};
+      color: #${background};
+    }
+  }
+
+  #custom-seperator {
+    color: #${alt1};
+    background-color: #${background};
+    border-bottom: 1px solid #${bright0};
+  }
+''