about summary refs log tree commit diff
path: root/home/profiles/base/config/waybar/settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/config/waybar/settings.nix')
-rw-r--r--home/profiles/base/config/waybar/settings.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/home/profiles/base/config/waybar/settings.nix b/home/profiles/base/config/waybar/settings.nix
index 09f32c1..12b65a4 100644
--- a/home/profiles/base/config/waybar/settings.nix
+++ b/home/profiles/base/config/waybar/settings.nix
@@ -5,9 +5,9 @@ with neotheme.colors;
   layer = "bottom";
   position = "top";
   height = 22;
-  modules-left = [ "pulseaudio" "custom/seperator" "cpu" "custom/seperator" "memory" ];
+  modules-left = [ "pulseaudio" "custom/separator" "cpu" "custom/separator" "memory" ];
   modules-center = [ "sway/workspaces" ];
-  modules-right = [ "clock" ];
+  modules-right = [ "battery" "custom/separator" "clock" ];
 
   "sway/workspaces" = {
     all-outputs = true;
@@ -47,7 +47,12 @@ with neotheme.colors;
     format = "<span foreground='#${color3}'>MEM</span> {used:0.2f}GiB";
   };
 
-  "custom/seperator" = {
+  "battery" = {
+    format = "<span foreground='#${color6}'>BATT</span> AA {capacity}%";
+    format-alt = "<span foreground='#${color6}'>PWR</span> {power}Wh";
+  };
+
+  "custom/separator" = {
     format = "|";
     interval = "once";
     tooltip = false;