about summary refs log tree commit diff
path: root/home/profiles/base/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/default.nix')
-rw-r--r--home/profiles/base/default.nix129
1 files changed, 10 insertions, 119 deletions
diff --git a/home/profiles/base/default.nix b/home/profiles/base/default.nix
index 6c68973..ed2e89b 100644
--- a/home/profiles/base/default.nix
+++ b/home/profiles/base/default.nix
@@ -9,7 +9,6 @@ in
     ../../modules/programs/nixpkgs
     ../../modules/programs/zshell
     #../../modules/programs/zellij
-    ../../modules/misc/neotheme
   ];
 
   options.profiles.base.enable = lib.mkEnableOption
@@ -23,59 +22,8 @@ in
       GIT_EDITOR = EDITOR;
     };
 
-    gtk.enable = true;
-    gtk.iconTheme.package = pkgs.papirus-icon-theme;
-    gtk.iconTheme.name = "Papirus-Dark";
-    gtk.theme.package = (pkgs.orchis-theme.override { tweaks = [ "primary" "compact" ]; });
-    gtk.theme.name = "Orchis-dark-compact";
-    gtk.font.name = "Dina 10";
-
-    home.file.".icons/default".source = "${pkgs.vanilla-dmz}/share/icons/Vanilla-DMZ-AA";
-
-    neotheme = {
-      name = "Softjelly";
-      identifier = "softjelly";
-
-      colors = {
-        background = "151515";
-        foreground = "cbc0ab";
-        alt0 = "404040";
-        alt1 = "606060";
-        color0 = "3c3c3c";
-        color1 = "cf6a4c";
-        color2 = "99ad6a";
-        color3 = "dfa358";
-        color4 = "8197bf";
-        color5 = "b3a3ff";
-        color6 = "8fbfdc";
-        color7 = "cbc0ab";
-        bright0 = "4c4c4c";
-        bright1 = "d98870";
-        bright2 = "adbd88";
-        bright3 = "e5b579";
-        bright4 = "9aaccc";
-        bright5 = "c2b5ff";
-        bright6 = "a5cce3";
-        bright7 = "d5cdbc";
-      };
-    };
-
     home.keyboard.layout = "us";
     home.packages = [
-      # Sway
-      pkgs.autotiling
-      pkgs.swaylock-effects
-      pkgs.swaybg
-      pkgs.wayland-utils
-      pkgs.wl-clipboard
-      pkgs.grim
-      pkgs.slurp
-      pkgs.sway-contrib.grimshot
-      pkgs.waybar
-      pkgs.bemenu
-      pkgs.qt5.qtwayland
-      pkgs.xdg-utils
-
       # Nix Tools
       pkgs.nix-index
       pkgs.nix-tree
@@ -88,8 +36,7 @@ in
       pkgs.bottom
       pkgs.croc
       pkgs.fd
-      # Fix gpg not recognizing foot terminfo
-      pkgs.foot.terminfo
+
       pkgs.fzf
       pkgs.libnotify
       pkgs.procs
@@ -109,26 +56,6 @@ in
     ];
 
 
-    wayland.windowManager.sway = {
-      enable = true;
-
-      wrapperFeatures = {
-        base = true;
-        gtk = true;
-      };
-
-      config = {
-        bars = [{ command = "${pkgs.waybar}/bin/waybar"; }];
-        keybindings = { };
-      };
-
-      extraSessionCommands = ''
-        export XDG_CURRENT_DESKTOP=sway;
-      '';
-
-      extraConfig = import ./config/sway.nix { inherit pkgs neotheme; };
-    };
-
     programs = {
       bat.enable = true;
       direnv.enable = true;
@@ -147,12 +74,6 @@ in
         };
       };
 
-      foot = {
-        enable = true;
-
-        settings = import ./config/foot.nix { inherit neotheme; };
-      };
-
       tmux = {
         enable = true;
 
@@ -167,13 +88,7 @@ in
         extraConfig = import ./config/tmux.nix;
       };
 
-      waybar = {
-        enable = config.wayland.windowManager.sway.enable;
 
-        settings = [ (import ./config/waybar/settings.nix { inherit neotheme; }) ];
-
-        style = import ./config/waybar/style.nix { inherit neotheme; };
-      };
 
       zsh = {
         enable = true;
@@ -264,12 +179,7 @@ in
     };
 
     services = {
-      dunst = {
-        enable = true;
-        settings = import ./config/dunst.nix { inherit neotheme; };
-      };
-
-      gpg-agent = {
+      gpg-agent = lib.mkIf pkgs.stdenv.isLinux {
         enable = true;
         pinentryFlavor = "gtk2";
         defaultCacheTtl = 3600;
@@ -282,33 +192,14 @@ in
           allow-preset-passphrase
         '';
       };
-
-      swayidle = {
-        enable = true;
-        events = [
-          { event = "before-sleep"; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
-          { event = "lock"; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
-        ];
-        timeouts = [
-          { timeout = 270; command = "${pkgs.libnotify}/bin/notify-send -t 30000 'Locking screen in 30 seconds'"; }
-          { timeout = 300; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
-          {
-            timeout = 600;
-            command = "${pkgs.sway}/bin/swaymsg 'output * dpms off'";
-            resumeCommand = "${pkgs.sway}/bin/swaymsg 'output * dpms on'";
-          }
-          {
-            timeout = 900;
-            command = "${pkgs.systemd}/bin/systemctl suspend";
-          }
-        ];
-      };
-
-      wlsunset = {
-        enable = true;
-        latitude = "36.5";
-        longitude = "127.2";
-      };
     };
+
+    home.file."${config.programs.gpg.homedir}/gpg-agent.conf".text = lib.mkIf pkgs.stdenv.isDarwin ''
+      default-cache-ttl 3600
+      default-cache-ttl-ssh 3600
+      pinentry-program ${pkgs.pinentry_mac}/Applications/pinentry-mac.app/Contents/MacOS/pinentry-mac
+      allow-preset-passphrase
+      enable-ssh-support
+    '';
   };
 }