about summary refs log tree commit diff
path: root/home/profiles/browsing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/browsing/default.nix')
-rw-r--r--home/profiles/browsing/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/home/profiles/browsing/default.nix b/home/profiles/browsing/default.nix
index 396cc70..42e85f0 100644
--- a/home/profiles/browsing/default.nix
+++ b/home/profiles/browsing/default.nix
@@ -5,6 +5,14 @@ in
   options.profiles.browsing = {
     enable = lib.mkEnableOption
       "A profile that enables a browser for the GUI and the terminal";
+
+    hiDpi = lib.mkOption {
+      type = lib.types.bool;
+      default = false;
+      description = ''
+        Tweak the browsers for better readability on HiDPI screens
+      '';
+    };
   };
 
   config = lib.mkIf cfg.enable {
@@ -36,6 +44,9 @@ in
       settings = import ./qutebrowser-settings.nix // {
         url.default_page = "https://searx.be";
         url.start_pages = "https://searx.be";
+      } // lib.optionalAttrs (cfg.hiDpi) {
+        qt.highdpi = true;
+        fonts.default_size = "12pt";
       };
     };