about summary refs log tree commit diff
path: root/home/profiles/browsing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/browsing/default.nix')
-rw-r--r--home/profiles/browsing/default.nix20
1 files changed, 12 insertions, 8 deletions
diff --git a/home/profiles/browsing/default.nix b/home/profiles/browsing/default.nix
index 7ee3799..0c16ca6 100644
--- a/home/profiles/browsing/default.nix
+++ b/home/profiles/browsing/default.nix
@@ -28,6 +28,7 @@ in
       enable = true;
 
       searchEngines = {
+        DEFAULT = "https://kagi.com/search?q={}";
         g = "https://www.google.com/search?hl=en&q={}";
         ddg = "https://www.duckduckgo.com/?q={}";
         nw = "https://nixos.wiki/index.php?search={}";
@@ -44,6 +45,9 @@ in
 
 
       settings = import ./qutebrowser-settings.nix // {
+        url.default_page = "https://kagi.com";
+        url.start_pages = "https://kagi.com";
+
         # mimeApps: open links in new window
         new_instance_open_target = "window";
       } // lib.optionalAttrs (cfg.hiDpi) {
@@ -51,14 +55,14 @@ in
         fonts.default_size = "12pt";
       };
 
-      extraConfig = ''
-        with open('${fixSopsPrefix 1000 config.sops.secrets.kagi-query.path}') as f:
-          c.url.searchengines['DEFAULT'] = f.readline()
-        with open('${fixSopsPrefix 1000 config.sops.secrets.kagi-session.path}') as f:
-          k_session = f.readline()
-          c.url.default_page = k_session
-          c.url.start_pages = k_session
-      '';
+      # extraConfig = ''
+      #   with open('${fixSopsPrefix 1000 config.sops.secrets.kagi-query.path}') as f:
+      #     c.url.searchengines['DEFAULT'] = f.readline()
+      #   with open('${fixSopsPrefix 1000 config.sops.secrets.kagi-session.path}') as f:
+      #     k_session = f.readline()
+      #     c.url.default_page = k_session
+      #     c.url.start_pages = k_session
+      # '';
     };
 
     xdg.mimeApps = lib.mkIf pkgs.stdenv.isLinux {