about summary refs log tree commit diff
path: root/home/profiles/creative/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/creative/default.nix')
-rw-r--r--home/profiles/creative/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/profiles/creative/default.nix b/home/profiles/creative/default.nix
new file mode 100644
index 0000000..9369659
--- /dev/null
+++ b/home/profiles/creative/default.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.creative;
+in
+{
+  imports = [
+    ../../modules/programs/nixpkgs
+  ];
+
+  options.profiles.creative = {
+    enable = lib.mkEnableOption
+      "A profile that enables the system to be used for creating multimedia contents.";
+  };
+
+  config = lib.mkIf cfg.enable {
+    home.packages = with pkgs; [ inkscape krita kdenlive ];
+  };
+}