about summary refs log tree commit diff
path: root/home/profiles/gui/config/dunst.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/dunst.nix')
-rw-r--r--home/profiles/gui/config/dunst.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/home/profiles/gui/config/dunst.nix b/home/profiles/gui/config/dunst.nix
index 60ed15f..b614de5 100644
--- a/home/profiles/gui/config/dunst.nix
+++ b/home/profiles/gui/config/dunst.nix
@@ -1,6 +1,10 @@
-{ neotheme }:
+{ config, neotheme }:
 
 with neotheme.colors;
+
+let
+  guiCfg = config.profiles.gui;
+in
 {
   global = {
     padding = 8;
@@ -19,7 +23,7 @@ with neotheme.colors;
     word_wrap = true;
     show_indicators = false;
     format = "<b>%s</b>\\n\\n%b";
-    font = "Dina 10";
+    font = "${guiCfg.font.name} ${toString guiCfg.font.size}";
     frame_color = "#${color3}";
     separator_color = "auto";
     max_icon_size = 80;