about summary refs log tree commit diff
path: root/home/profiles/gui/config/foot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/foot.nix')
-rw-r--r--home/profiles/gui/config/foot.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/home/profiles/gui/config/foot.nix b/home/profiles/gui/config/foot.nix
index 9296b48..61fecf7 100644
--- a/home/profiles/gui/config/foot.nix
+++ b/home/profiles/gui/config/foot.nix
@@ -1,13 +1,16 @@
-{ neotheme }:
+{ config, neotheme }:
 
 with neotheme.colors;
 
+let
+  guiCfg = config.profiles.gui;
+in
 {
   main = {
     term = "foot";
-    font = "Dina:pixelsize=13,JetBrainsMono Nerd Font:pixelsize=12";
+    font = "${guiCfg.font.name}:pixelsize=${toString guiCfg.font.pixelSize},JetBrainsMono Nerd Font:pixelsize=12";
     letter-spacing = 0;
-    dpi-aware = "yes";
+    # dpi-aware = "yes";
     pad = "16x16 center";
   };