about summary refs log tree commit diff
path: root/home/profiles/gui/config/mako.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/mako.nix')
-rw-r--r--home/profiles/gui/config/mako.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/home/profiles/gui/config/mako.nix b/home/profiles/gui/config/mako.nix
new file mode 100644
index 0000000..a471a6a
--- /dev/null
+++ b/home/profiles/gui/config/mako.nix
@@ -0,0 +1,45 @@
+{ config, neotheme }:
+
+with neotheme.colors;
+
+let
+  guiCfg = config.profiles.gui;
+in
+{
+  anchor = "top-right";
+  width = 330;
+  padding = "8";
+  margin = "16,8";
+  borderRadius = 10;
+  borderSize = 2;
+
+  borderColor = "#${color3}";
+  backgroundColor = "#${background}";
+  textColor = "#${foreground}";
+  progressColor = "over #${color5}";
+
+  markup = true;
+  font = "${guiCfg.font.name} ${toString guiCfg.font.size}";
+
+  maxVisible = 5;
+
+  extraConfig = ''
+    [urgency=low]
+    border-color=#${color4}
+    default-timeout=4000
+
+    [urgency=normal]
+    border-color=#${color3}
+    default-timeout=8000
+
+    [urgency=critical]
+    border-color=#${color1}
+    default-timeout=0
+
+    [app-name=yubikey-touch-detector]
+    anchor=bottom-center
+    text-alignment=center
+    padding=32
+
+  '';
+}