about summary refs log tree commit diff
path: root/home/profiles/gui/config/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/sway.nix')
-rw-r--r--home/profiles/gui/config/sway.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/home/profiles/gui/config/sway.nix b/home/profiles/gui/config/sway.nix
index 174b47e..dddf9d9 100644
--- a/home/profiles/gui/config/sway.nix
+++ b/home/profiles/gui/config/sway.nix
@@ -2,6 +2,9 @@
 
 with neotheme.colors;
 
+let
+  guiCfg = config.profiles.gui;
+in
 ''
   # disable power key
   exec systemd-inhibit --what=handle-power-key --who="sway" --why="Sway manages power key behaviour" sleep infinity
@@ -25,7 +28,7 @@ with neotheme.colors;
   bindsym $mod+Return exec $term
 
   # set menu
-    set $menu "${pkgs.bemenu}/bin/bemenu-run -H 18 -l 5 --fn 'Dina 13px' -p 'run::' --tb '$primary' --tf '$color0' --hb '$primary' --hf '$color0'"
+    set $menu "${pkgs.bemenu}/bin/bemenu-run -H 18 -l 5 --fn '${guiCfg.font.name} ${toString guiCfg.font.pixelSize}px' -p 'run::' --tb '$primary' --tf '$color0' --hb '$primary' --hf '$color0'"
   bindsym $mod+d exec $menu
 
   # set screenshot util
@@ -68,7 +71,7 @@ with neotheme.colors;
   # kill focused
   bindsym $mod+w kill
 
-  font "pango:Dina 10"
+  font "pango:${guiCfg.font.name} ${toString guiCfg.font.size}"
 
   # window rules
   for_window [window_role="pop-up"]      floating enable
@@ -199,8 +202,9 @@ with neotheme.colors;
   client.unfocused        $muted $muted $color7 $muted
   client.urgent           $color10 $color10 $color0 $color10
   output "*" bg ${../../../../assets/annie-spratt-arctic.jpg} fill
-  output "*" scale 1
-  output "*" scale_filter nearest
+  output eDP-1 scale 1.25
+  # output "*" scale 1
+  # output "*" scale_filter smart
 
   input type:touchpad {
     tap enabled