about summary refs log tree commit diff
path: root/home/profiles/gui/config/waybar/settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/waybar/settings.nix')
-rw-r--r--home/profiles/gui/config/waybar/settings.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/home/profiles/gui/config/waybar/settings.nix b/home/profiles/gui/config/waybar/settings.nix
index 8cb2b5e..1529378 100644
--- a/home/profiles/gui/config/waybar/settings.nix
+++ b/home/profiles/gui/config/waybar/settings.nix
@@ -11,7 +11,7 @@ in
   height = 22;
   modules-left = [ "wireplumber" "custom/separator" "cpu" "custom/separator" "memory" "custom/separator" "idle_inhibitor" ];
   modules-center = [ "sway/workspaces" ];
-  modules-right = [ "tray" "network" "custom/separator" ]
+  modules-right = [ "group/tray" "custom/separator" "network" "custom/separator" ]
     ++ lib.optionals (guiCfg.laptop.enable) [ "battery" "custom/separator" ]
     ++ [ "clock" ];
 
@@ -74,10 +74,27 @@ in
     format = "<span foreground='#a89984'>CAFFEINE</span> {status}";
   };
 
+  "group/tray" = {
+    orientation = "inherit";
+    drawer = {
+      transition-duration = 500;
+    };
+    modules = [
+      "custom/tray-placeholder"
+      "tray"
+    ];
+  };
+
   "tray" = {
     spacing = 5;
   };
 
+  "custom/tray-placeholder" = {
+    format = "Tray >";
+    interval = "once";
+    tooltip = false;
+  };
+
   "custom/separator" = {
     format = "|";
     interval = "once";