about summary refs log tree commit diff
path: root/home/profiles/gui/config/waybar/settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/waybar/settings.nix')
-rw-r--r--home/profiles/gui/config/waybar/settings.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/home/profiles/gui/config/waybar/settings.nix b/home/profiles/gui/config/waybar/settings.nix
new file mode 100644
index 0000000..86e865a
--- /dev/null
+++ b/home/profiles/gui/config/waybar/settings.nix
@@ -0,0 +1,64 @@
+{ neotheme }:
+
+with neotheme.colors;
+{
+  layer = "bottom";
+  position = "top";
+  height = 22;
+  modules-left = [ "pulseaudio" "custom/separator" "cpu" "custom/separator" "memory" "custom/separator" "idle_inhibitor" ];
+  modules-center = [ "sway/workspaces" ];
+  modules-right = [ "battery" "custom/separator" "clock" ];
+
+  "sway/workspaces" = {
+    all-outputs = true;
+    disable-scroll = false;
+    format = "{name}";
+    persistent_workspaces = {
+      "1:I" = [ ];
+      "2:II" = [ ];
+      "3:III" = [ ];
+      "4:IV" = [ ];
+      "5:V" = [ ];
+      "6:VI" = [ ];
+      "7:VII" = [ ];
+      "8:VIII" = [ ];
+      "9:IX" = [ ];
+      "10:X" = [ ];
+    };
+  };
+
+  "clock" = {
+    interval = 10;
+    format = "<span foreground='#${color5}'>TIME</span> {:%A, %b %d %H:%M}";
+  };
+
+  "cpu" = {
+    interval = 5;
+    format = "<span foreground='#${color2}'>CPU</span> {usage:2}%";
+  };
+
+  "pulseaudio" = {
+    format = "<span foreground='#${color4}'>VOL</span> {volume}%";
+    format-muted = "<span foreground='#${color4}'>VOL</span> Muted";
+  };
+
+  "memory" = {
+    interval = 5;
+    format = "<span foreground='#${color3}'>MEM</span> {used:0.2f}GiB";
+  };
+
+  "battery" = {
+    format = "<span foreground='#${color6}'>BATT</span> {capacity}%";
+    format-alt = "<span foreground='#${color6}'>PWR</span> {power}Wh";
+  };
+
+  "idle_inhibitor" = {
+    format = "<span foreground='#a89984'>CAFFEINE</span> {status}";
+  };
+
+  "custom/separator" = {
+    format = "|";
+    interval = "once";
+    tooltip = false;
+  };
+}