about summary refs log tree commit diff
path: root/home/profiles/gui/config/waybar/style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/waybar/style.nix')
-rw-r--r--home/profiles/gui/config/waybar/style.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/home/profiles/gui/config/waybar/style.nix b/home/profiles/gui/config/waybar/style.nix
index 92eb772..1f5327e 100644
--- a/home/profiles/gui/config/waybar/style.nix
+++ b/home/profiles/gui/config/waybar/style.nix
@@ -73,6 +73,21 @@ in
     border-bottom: 1px solid #${bright0};
   }
 
+  @keyframes blinkBattery {
+    to {
+      border-color: #${color3};
+    }
+  }
+
+  #battery.charging {
+    border-bottom: 1px solid transparent;
+    animation-name: blinkBattery;
+    animation-duration: 1s;
+    animation-timing-function: steps(12);
+    animation-iteration-count: infinite;
+    animation-direction: alternate;
+  }
+
   #tray {
     /* TODO: https://github.com/Alexays/Waybar/issues/2906 */
     margin: 0;
@@ -92,6 +107,10 @@ in
     padding-right: 0.2rem;
   }
 
+  #custom-scratchpad-indicator {
+    color: #f0a0c0;
+  }
+
   #custom-separator {
     color: #${alt1};
     background-color: #${background};