about summary refs log tree commit diff
path: root/home/profiles/gui/config/waybar/style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/config/waybar/style.nix')
-rw-r--r--home/profiles/gui/config/waybar/style.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/home/profiles/gui/config/waybar/style.nix b/home/profiles/gui/config/waybar/style.nix
index d8714ed..5009ccb 100644
--- a/home/profiles/gui/config/waybar/style.nix
+++ b/home/profiles/gui/config/waybar/style.nix
@@ -1,13 +1,16 @@
-{ neotheme }:
+{ config, neotheme }:
 
 with neotheme.colors;
 
+let
+  guiCfg = config.profiles.gui;
+in
 ''
   * {
     border: none;
     border-radius: 0;
-    font-family: "Dina, JetBrainsMono Nerd Font";
-    font-size: 12px;
+    font-family: "${guiCfg.font.name}, JetBrainsMono Nerd Font";
+    font-size: ${toString guiCfg.font.pixelSize}px;
     min-height: 0;
   }