about summary refs log tree commit diff
path: root/home/profiles/gui/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/default.nix')
-rw-r--r--home/profiles/gui/default.nix50
1 files changed, 43 insertions, 7 deletions
diff --git a/home/profiles/gui/default.nix b/home/profiles/gui/default.nix
index 8ed2409..65d2c4a 100644
--- a/home/profiles/gui/default.nix
+++ b/home/profiles/gui/default.nix
@@ -9,8 +9,30 @@ in
     ../../modules/misc/neotheme
   ];
 
-  options.profiles.gui.enable = lib.mkEnableOption
-    "The gui profile, sets up sway and related applications.";
+  options.profiles.gui = {
+    enable = lib.mkEnableOption
+      "The gui profile, sets up sway and related applications.";
+
+    font = {
+      name = lib.mkOption {
+        type = lib.types.str;
+        default = "Dina";
+        description = "Name of the primary font";
+      };
+
+      size = lib.mkOption {
+        type = lib.types.number;
+        default = 10;
+        description = "Size for the primary font";
+      };
+
+      pixelSize = lib.mkOption {
+        type = lib.types.number;
+        default = 13;
+        description = "Pixelsize(px) for the primary font";
+      };
+    };
+  };
 
   config = lib.mkIf cfg.enable {
     gtk.enable = true;
@@ -18,7 +40,7 @@ in
     gtk.iconTheme.name = "Papirus-Dark";
     gtk.theme.package = (pkgs.orchis-theme.override { tweaks = [ "primary" "compact" ]; });
     gtk.theme.name = "Orchis-dark-compact";
-    gtk.font.name = "Dina 10";
+    gtk.font.name = "${cfg.font.name} ${toString cfg.font.size}";
 
     home.file.".icons/default".source = "${pkgs.vanilla-dmz}/share/icons/Vanilla-DMZ-AA";
 
@@ -87,7 +109,7 @@ in
       };
 
       extraSessionCommands = ''
-        export XDG_CURRENT_DESKTOP=sway;
+        . "${config.home.profileDirectory}/etc/profile.d/hm-session-vars.sh"
       '';
 
       extraConfig = import ./config/sway.nix { inherit config pkgs neotheme; };
@@ -103,7 +125,7 @@ in
       foot = {
         enable = true;
 
-        settings = import ./config/foot.nix { inherit neotheme; };
+        settings = import ./config/foot.nix { inherit config neotheme; };
       };
 
       waybar = {
@@ -111,14 +133,28 @@ in
 
         settings = [ (import ./config/waybar/settings.nix { inherit neotheme; }) ];
 
-        style = import ./config/waybar/style.nix { inherit neotheme; };
+        style = import ./config/waybar/style.nix { inherit config neotheme; };
       };
     };
 
     services = {
       dunst = {
         enable = true;
-        settings = import ./config/dunst.nix { inherit neotheme; };
+        settings = import ./config/dunst.nix { inherit config neotheme; };
+      };
+
+      kanshi = {
+        enable = true;
+        profiles = {
+          haruka-standalone = {
+            outputs = [
+              {
+                criteria = "AU Optronics 0xD291 Unknown";
+                scale = 1.25;
+              }
+            ];
+          };
+        };
       };
 
       swayidle =