about summary refs log tree commit diff
path: root/home/profiles/gui/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/default.nix')
-rw-r--r--home/profiles/gui/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/home/profiles/gui/default.nix b/home/profiles/gui/default.nix
index 1d611b0..139307a 100644
--- a/home/profiles/gui/default.nix
+++ b/home/profiles/gui/default.nix
@@ -53,7 +53,7 @@ in
     home.packages = [
       # Sway
       pkgs.autotiling
-      pkgs.swaylock
+      pkgs.swaylock-effects
       pkgs.swaybg
       pkgs.wayland-utils
       pkgs.wl-clipboard
@@ -124,14 +124,14 @@ in
       swayidle = {
         enable = true;
         events = [
-          { event = "before-sleep"; command = "${pkgs.swaylock}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2"; }
-          { event = "lock"; command = "${pkgs.swaylock}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2"; }
+          { event = "before-sleep"; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
+          { event = "lock"; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
         ];
         timeouts = [
           # 4m30s
           { timeout = 270; command = "${pkgs.libnotify}/bin/notify-send -t 30000 'Locking screen in 30 seconds'"; }
           # 5m
-          { timeout = 300; command = "${pkgs.swaylock}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2"; }
+          { timeout = 300; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
           # 10m
           {
             timeout = 600;